跳转至

编辑和删除对象

修改对象的操作顺序

以下过程描述如何在 Tagetik 文档中编辑和删除对象

  1. 修改复选框或自由文本
  2. 修改下拉列表
  3. 修改属性维度
  4. 修改金额
  5. 修改表格或图表
  6. 删除对象

修改复选框或自由文本对象

Word Add-in > CCH® Tagetik Disclosure ribbon bar > Objects > Edit

  1. 在文档中选择一个复选框或自由文本对象
  2. 单击 Edit:这将打开 Edit Object 选项卡,您可以在其中:
  3. 单击 Delete 从文档中删除复选框或自由文本对象
  4. 更改名称
  5. 或编辑附加信息
  6. 单击 Save 保存刚刚所做的更改“Edit object completed”

修改下拉列表对象

Word Add-in > CCH® Tagetik Disclosure ribbon bar > Objects > Edit

  1. 在文档中选择一个下拉列表对象
  2. 单击 EditEdit Object 选项卡将打开:
  3. 单击 Delete 按钮从文档中删除下拉列表对象
  4. 更改名称
  5. 或编辑附加信息
  6. 单击 Save 保存刚刚仅对常规信息所做的更改
  7. 单击 Source 选项卡以编辑 Name 和 Value 字段,或通过选择垃圾桶删除一行
  8. 或单击 Add Item 添加新行
  9. 在必填字段中输入名称和值
  10. 单击 Save 保存对源数据所做的更改

编辑属性维度对象

Word Add-in > CCH® Tagetik Disclosure ribbon bar > Objects > Edit

  1. 在文档中选择一个属性维度对象
  2. 单击 EditEdit AttributeDim 选项卡将打开,您可以在其中:
  3. 单击 Delete 从文档中删除属性维度对象
  4. 单击已启用的 Update 按钮,以在服务器端进行了更改的情况下更新数据
  5. 更改名称
  6. 或编辑附加信息
  7. 单击 Save 保存刚刚仅对常规信息所做的更改
  8. 单击 Source 选项卡以显示已填写的源字段
  9. 如果用户有其他关联的数据库,则单击 Application 选择另一个数据库
  10. 单击 Dimension
  11. 从系统显示的列表中选择另一个维度,而不是先前选择的维度
  12. 单击系统刚刚添加的 Dimension 字段
  13. 从层次或平铺列表中选择一个项,例如 Entity - New York,或选择多个元素
  14. 单击 Attribute 下拉列表
  15. 从系统显示的列表中选择另一个属性
  16. 单击 Save 按钮保存对 Source 选项卡所做的更改

注意 如果用户已添加或想要添加 Currency 维度,并从下拉列表 Attribute → Average Fx rate - Final FX rate 和 Period FX rate 中选择以下属性,系统会将 Scenario 和 Period 添加为必填维度,需要填写/编辑以完成对象输入。

修改金额对象

Word Add-in > CCH® Tagetik Disclosure ribbon bar > Objects > Edit

  1. 在文档中选择一个金额对象
  2. 单击 EditEdit Amount 选项卡将弹出,您可以在其中:
  3. 单击 Delete 从文档中移除金额对象
  4. 单击已启用的 Update 按钮,以在服务器端进行了更改的情况下更新数据
  5. 更改名称
  6. 或编辑附加信息
  7. 单击 Save 保存刚刚仅对常规信息所做的更改
  8. 单击 Source 选项卡以显示已填写的源字段

对于从数据库添加的金额 - Format as 字段设置为 Tagetik:

  1. 如果用户有其他关联的数据库,则单击 Application 下拉列表选择另一个数据库
  2. 单击 Account 字段
  3. 从层次列表下拉列表中选择一个项,例如 Account - Default view | Balance sheet,或选择多个项
  4. 选择 Confirm 按钮,通过添加项返回上一页
  5. 或选择 Cancel 按钮不确认并返回上一屏幕
  6. 单击 Scenario 字段
  7. 从层次列表下拉列表中选择一个项,例如 Scenario - 2022 Budget,或选择多个项
  8. 选择 Confirm 按钮,通过添加项返回上一页
  9. 或选择 Cancel 按钮不确认并返回上一屏幕
  10. 单击 Period 字段
  11. 从平铺列表中仅选择一个项,例如 10 - October
  12. 选择 Confirm 按钮,通过添加项返回上一页
  13. 单击 Insert 按钮将金额对象插入文档中

如果要添加新维度,请单击 Add Dimension,然后从系统显示的列表中选择一个项

  • 单击新添加的维度字段
  • 从层次或平铺列表中选择项,然后选择 Confirm 按钮添加该项

对于从外部源(Sharepoint 上的 excel 文件)添加的金额 - Format as 字段应填写为 Excel

  1. 单击 File 从 Sharepoint 选择另一个外部源
  2. 单击 Sheet 从外部源文件中选择一个工作表
  3. 选择 Select Area 选项,然后单击 Area 选择区域,或选择 Custom Selection 选项并在 Cell 字段中指明包含金额的单元格

  4. 单击 Advanced 选项卡以进入第二个 Advanced 3/3

  5. 用户可以将先前选择的值更改为 Number 或 Percentage,在两种格式之间切换
  6. 启用或禁用 Inherit Format 切换开关,以保持或不保持从文档格式继承。
  7. 单击侧面板右下角的 SAVE,系统将更新:

  8. 仅元数据(如果仅编辑了 Object Name)

  9. 元数据和刷新(如果编辑了 Object Name 和/或 Additional info 和/或 Dimensional values)

修改表格对象

Word Add-in > CCH® Tagetik Disclosure ribbon bar > Objects > Edit

  1. 在文档中选择一个表格对象
  2. 单击 EditEdit Table 选项卡将弹出,您可以在其中:
  3. 单击 Delete 从文档中移除表格对象
  4. 系统始终将 DataStyle 切换开关显示为活动状态
  5. 如果用户选择已启用的 Update 按钮,并且 DataStyle 切换开关已启用,系统将在保持手动覆盖的同时启动更新,否则表格将在不保持手动覆盖的情况下更新
  6. 更改名称
  7. 或编辑附加信息
  8. 单击 Save 保存刚刚仅对常规信息所做的更改
  9. 单击 Source 选项卡以显示已填写的源字段

对于从数据库添加的表格 - Format As 字段应填写为 Tagetik

  1. 如果用户有其他关联的数据库,则单击 Application 选择另一个数据库
  2. 选择 Table 对象
  3. 插入附加信息(可选)
  4. 单击已启用的 Next 按钮以进入第二个 Source 选项卡 2/4
  5. 单击 Application 更改数据库(如果用户仅关联一个数据库,则默认设置)
  6. 单击 Form 字段
  7. 选择在文件夹下定义并保存在先前所选数据库上的另一个表单
  8. 如果所选表单未定义工作表/区域,系统将显示消息“No area available”。
  9. 单击 Sheet
  10. 从列表中选择另一个可用选项
  11. 单击 Area
  12. 从列表中选择另一个可用选项
  13. 单击 Parameters 选项卡以访问第三个 Parameters 选项卡 ¾

  14. 如果表格未设置任何参数,系统将显示消息“No parameters available for this form”,用户可以选择通过选择 Previous 返回上一屏幕,或再次选择 Next 按钮进入最后格式化步骤。

  15. 如果表格先前设置了维度参数,系统将显示在创建阶段已填写的维度,用户可以单击某个维度并通过启用 Save 按钮选择另一个维度,或决定保留参数并转到 Advanced 选项卡。

  16. 如果表格先前设置了非维度参数(如 Data、Text、Dictionary、Flag、Numerical),用户可以单击三个点单击某个维度并选择另一个,然后选择 Confirm,否则他们可以决定保留参数并转到 Advanced 选项卡。

注意 必填参数带有星号,如果选择 Account - scenario - period 作为参数,这些参数始终设置为必填。

对于从外部源(Sharepoint 上的 excel 文件)添加的表格 - Format as 字段填写为 Excel

  1. 单击 File 从 Sharepoint 选择另一个外部源
  2. 单击 Sheet 从外部源文件中选择一个工作表
  3. 单击 Area 选择感兴趣的表格区域

  4. 单击 Advanced 选项卡以访问第四个也是最后一个 Advanced 选项卡 4/4

  5. 通过选择所需选项更改格式:
  6. Document root - 表格将根据创建文档时在 ADVANCED 部分的 Document Structure 下声明的设置插入并格式化。
  7. Source(默认选择)系统将按照 CCH Tagetik excel 中的格式显示格式化表格,并具有相同的格式。
  8. 或用户可以保持该选项不变
  9. 单击侧面板右下角的 SAVE 按钮,系统将更新:

  10. 仅元数据(如果仅编辑了 Object Name)

  11. 元数据和刷新(如果编辑了 Object Name、Sources、Parameters 和 Formatting)

删除对象

Word Add-in > CCH® Tagetik Disclosure ribbon bar > Objects > Edit

  1. 在文档中选择一个对象
  2. 单击 EditEdit Object 选项卡将弹出
  3. 单击 Delete 从文档中删除该对象
  4. 要确认删除,请按系统显示的 yes 命令